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1
Welcome

Welcome to CodeWarrior Professional from Metrowerks, a flexible, 
powerful, and easy to use programming package for Windows®, 
Mac®, Solaris™, Linux, and Java™. Use CodeWarrior Professional 
to write software in C, C++, or Java for Windows, Mac, Solaris, 
Linux, or Java VM.

Whether you’re new to programming or an experienced 
programmer using CodeWarrior for the first time, we want your 
programming experience to be good. For a start, read this guide as 
an introduction to CodeWarrior Professional.

Getting started

If you can’t wait to dive in and get started using CodeWarrior, see 
“Get Started, Quick!” on page 6.

What’s in this book

To find out the contents of this book, see “About this Book” on page 
7.

Getting help

Got a problem you can’t solve?  See “Metrowerks Support” on page 
79 for information on contacting Metrowerks for technical and 
customer support.
QuickStart Professional QSP–5 
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Get Started, Quick!

              
Get Started, Quick!
The quickest way to learn about CodeWarrior is to follow the steps 
below.

1. Read the software license.

Please read the “Metrowerks Software License Agreement” on page 
85 and make sure you understand and agree with it before installing 
your new software.

2. Register CodeWarrior.

Make sure you’ve registered your software to receive technical 
support and any factory updates you might be entitled to. See 
“Registering CodeWarrior” on page 9 for more information.

3. Introduce yourself to CodeWarrior.

See “Overview” on page 11 to learn about using the different parts 
of CodeWarrior to develop software.

4. Install CodeWarrior.

To install your new software on your computer, follow the 
directions for your computer system: 

• see “Windows® Installation and Programming of 
CodeWarrior®” on page 19 to install CodeWarrior  on Windows 
and create a small application.

• see “Mac® Installation and Programming of CodeWarrior®” on 
page 27 to install CodeWarrior on the Mac and write a small 
application.

• see “Solaris™ Installation and Programming of CodeWarrior®” 
on page 35 to install CodeWarrior for Solaris and create an 
application.

• see “Linux Installation and Programming of CodeWarrior®” on 
page 43 to install CodeWarrior for Linux and create an 
application.

5. Take a tour of the CodeWarrior IDE.

Turn to “A Quick Tour of CodeWarrior” on page 53 for a short, 
step-by-step exploration of the CodeWarrior IDE (Integrated 
Development Environment), the center of CodeWarrior software 
development.
QSP–6 QuickStart Professional



 

Welcome

 

About this Book

          
6. Learn about the rest of CodeWarrior.

See “CodeWarrior Documentation” on page 71 to learn more  about 
other features of CodeWarrior and its documentation.

About this Book
 QuickStart Professional  covers:

• what’s in the CodeWarrior Professional software package

• how to install CodeWarrior Professional

• a brief introduction to the CodeWarrior IDE (Integrated 
Development Environment), the center of CodeWarrior software 
development

• where to find more information on using CodeWarrior

• getting technical and customer support from Metrowerks

• Information about CodeWarrior Year 2000 Compliance 

The chapters in QuickStart Professional cover the topics shown in 
Table 1.1.
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Table 1.1 Chapters in this book and the topics they cover

This chapter… covers these topics

“Welcome” on page 5 introduction to this book, the CodeWarrior 
Reference Web Site, getting started, eligibility for 
free and discounted updates, Metrowerks Year 
2000 policy, what’s new, what you should know 
before using CodeWarrior 

“Overview” on page 11 programming tools, host platforms, programming 
languages, target platforms, application 
frameworks, introduction to documentation and 
example projects 

“Windows® Installation and 
Programming of CodeWarrior®” 
on page 19

system requirements and steps to install 
CodeWarrior on Microsoft Windows

“Mac® Installation and 
Programming of CodeWarrior®” 
on page 27

system requirements and steps to install 
CodeWarrior on the Mac

“Solaris™ Installation and 
Programming of CodeWarrior®” 
on page 35

system requirements, steps to install CodeWarrior 
on machines running Solaris

“Linux Installation and 
Programming of CodeWarrior®” 
on page 43

system requirements, steps to install CodeWarrior 
on machines running Linux 

“A Quick Tour of CodeWarrior” 
on page 53

brief introduction to the CodeWarrior IDE, the 
center of CodeWarrior software development

“CodeWarrior Documentation” 
on page 71 

covers detailed information about CodeWarrior 
Online Help, documentation, and third-party 
references and books

“Metrowerks Support” on page 
79

contacting Metrowerks and its distributors for 
technical support, customer support, and other 
services

“Metrowerks Software License 
Agreement” on page 85

the conditions to using this software
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Registering CodeWarrior
Did you just buy this software?

If this is the first time you’ve purchased CodeWarrior, fill in the 
registration card and send it to Metrowerks to be eligible for 
receiving our world class technical support.

See “Registering a CodeWarrior Product” on page 80 for details on 
registering your new Metrowerks product.

See “Technical Support” on page 81 for more information on the 
technical support options available to you.

What’s New
To find out what’s new with CodeWarrior Professional, see:

• What’s New release note

The What’s New release note is located in the top directory of 
the CodeWarrior CD-ROM. It contains a broad overview of 
the major changes offered in this release of CodeWarrior.

• Release Notes  folder

The Release  Notes  folder on the CD contains detailed 
release notes for the software in this product. 

• Metrowerks documentation

Finally, many of the Metrowerks documentation manuals 
contain a What’s New section describing new features.
QuickStart Professional QSP–9 
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CodeWarrior Year 2000 Compliance
The Products provided by Metrowerks under the License 
agreement process dates only to the extent that the Products use 
date data provided by the host or target operating system for date 
representations used in internal processes, such as file 
modifications. Any Year 2000 Compliance issues resulting from the 
operation of the Products are therefore necessarily subject to the 
Year 2000 Compliance of the relevant host or target operating 
system. Metrowerks directs you to the relevant statements of 
Microsoft Corporation, Sun Microsystems, Inc., Apple Computer, 
Inc., and other host or target operating systems relating to the Year 
2000 Compliance of their operating systems. Except as expressly 
described above, the Products, in themselves, do not process date 
data and therefore do not implicate Year 2000 Compliance issues.

For additional information, visit: 

http://www.metrowerks.com/about/y2k.html

What You Should Know
To get the most out of this software, you should be familiar with 
operating your computer, using the mouse, menus, buttons, 
windows, clicking, dragging, and so on. If you’re not familiar with 
these terms or the actions associated with them, please refer to the 
instructions in the user’s guide or the on-line help system that come 
with your computer.
QSP–10 QuickStart Professional



              
2
Overview

This chapter introduces you to the CodeWarrior development 
universe. With CodeWarrior, no programming project is out of your 
reach. The overview covers the following topics:

• The CodeWarrior IDE

• Multiple Programming Hosts

• Multiple Languages

• Multiple Programming Targets

• Libraries and Application Frameworks

• CodeWarrior Documentation

The CodeWarrior IDE
The CodeWarrior IDE (Integrated Development Environment) is 
the center of CodeWarrior software development. The IDE offers:

• Power – From the IDE you can edit, browse, compile, link, and 
run your project. The IDE includes a text editor, class browser, 
and a project manager to help you do all your programming 
tasks easily and quickly. 

• Flexibility – Plug-in compilers and linkers support many 
different platforms and processors. The same powerful IDE is 
used to develop and generate software for such targets as 
Win32®/Intel, Mac OS®, Solaris, MIPS™, Motorola® 680x0, 
PowerPC™, and Linux.

• Convenience – The IDE running both on Windows, Mac OS, 
Solaris, and Linux are based on the same technology. Because 
the IDE and its plug-ins operate identically for all platforms, 
developers who program on multiple platforms save time and 
effort using the familiar CodeWarrior tools for all their projects. 
QuickStart Professional QSP–11 
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The IDE’s core tools are the tightly and transparently integrated 
primary components used to write code. Table 2.1 describes some of 
the individual components included with the CodeWarrior IDE.

Table 2.1 The IDE’s core tools

This tool… Provides these features and functions

project manager Use the commands in the IDE’s Project menu to gather all the 
files of a program together along with configurable sets of 
options into a project file.  It also decides the plugin 
compilers and linkers to create the final program.

rapid application 
development

CodeWarrior now offers tools to automate new applications 
to handle the coding of generic intialization routines and the 
drawing of user interface elements.

source code editor Use the commands in the Edit and Search menus, and the 
controls in the IDE’s editor windows to edit source code and 
text. Some of the editor’s features are:

• edit, search, and replace text in one file or several files
• split an editor window into multiple panes
• toggle between a source file and its related interface file
• open an interface file referred to by a source file
• set markers at arbitrary locations in a text file
• jump to any routine in any file instantly
• customize the source code display

browser Use the commands in the Window menu, features in any 
source code view, and controls in the browser’s window to 
get quick, intuitive access to the definitions of classes, 
variables, routines, enumerations, and other source code 
elements.
QSP–12 QuickStart Professional
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Multiple Programming Hosts
Some Metrowerks products do not include support for all available 
core tools. See the documentation to determine which core tools are 
included in your package.

Multiple Programming Hosts
Metrowerks CodeWarrior is currently hosted on these platforms:

• Windows 95 or Windows NT

• Mac OS (68K or PowerPC)

• Solaris

• Linux

This makes it easy to switch to another platform as your 
programming requirements change while retaining the familiar 
CodeWarrior development environment. Furthermore, projects 
from one host can be opened by any of the other hosts. This feature 
provides an enormous boost in productivity when developing on 
multiple platforms. 

compilers and linkers Thanks to its plugin architecture, the IDE is able to play host 
to a limitless variety of compilers and linkers to generate 
software for several operating system and processor 
platforms. 

debugger Use the commands in the Window, Debug, and Data menus 
to control your program, step through its source code or 
assembly statements, set breakpoints, set watchpoints, and 
examine its data while it executes. The IDE’s debugger works 
with all kinds of code in all the supported languages—C, 
C++, Pascal, and Java. Use the debugger to debug libraries, 
executables, multiple threads, and processes. The debugger 
also supports debugging code running on multiple 
processors.

This tool… Provides these features and functions
QuickStart Professional QSP–13 
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Multiple Languages
CodeWarrior Professional supports development with the most 
common languages used by professional programmers today: C, 
C++, Java, and Pascal. Table 2.2 shows the list of compilers 
Metrowerks provides to generate software for its target platforms.

Table 2.2 Language supported for targets

Some Metrowerks products do not include support for all available 
languages. See the documentation to determine which language(s) 
are included in your package.

Target platform C C++ Java

Java Virtual Machine •

Linux • •

Mac OS 
(68K and PowerPC)

• • •

Palm OS • •

Solaris • • •

Sony PlayStation or 
Net Yaroze

• •

Win32/Intel • • •
QSP–14 QuickStart Professional
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Multiple Programming Targets
Use CodeWarrior on your host system to write software for many 
operating system and processor platforms (targets). Table 2.3 shows 
you some of the major targets supported by each host.

Table 2.3 Programming targets and their host development platforms

The CodeWarrior product you purchased does not include 
compilers and linkers for every possible target. Check 
“CodeWarrior Documentation” on page 71 and the appropriate 
manual for a list of targets supported by the product.

Libraries and Application Frameworks
Standard libraries

CodeWarrior includes standard libraries with its compilers, when 
appropriate for a target platform. CodeWarrior Professional 
includes MSL (Metrowerks Standard Library) for C and C++ for 
Win32/Intel and Mac OS. MSL C and MSL C++ are ANSI-
conformant standard libraries. 

Target libraries

To access the services and features of a target platform’s operating 
system, the CodeWarrior IDE/Integrated Debugger also includes 
libraries and interface files from the target platform’s manufacturer. 
For example, CodeWarrior Professional comes with Microsoft’s 

Target platform Windows Mac OS Solaris Linux

Java Virtual Machine • • •

Mac OS (68K & PPC) • •

Palm OS • •

Solaris •

Sony PlayStation or 
Net Yaroze

• •

Win32/Intel • • •
QuickStart Professional QSP–15 
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CodeWarrior Documentation
Win32 SDK header files to develop software for the Win32/Intel 
platform.

Application frameworks

Programming for modern, graphical operating systems like 
Windows 95/98/NT, Mac OS, and Java is non-trivial, and that’s 
where an application framework helps. A framework supplies 
standardized code to handle many common programming tasks, 
making the creation and design of a new application much easier 
and faster. 

The CodeWarrior comes with several complete application 
frameworks, one for each major CodeWarrior target. 

Table 2.4 Frameworks supported

CodeWarrior Documentation
CodeWarrior comes with a wealth of online documentation. This is 
found in the Documentation  folder on the CodeWarrior CD-ROM. 
For more information on using the documentation to learn about 
CodeWarrior, see “CodeWarrior Documentation” on page 71.

Finding information for a specific target platform

To learn the use of CodeWarrior to develop software for a particular 
target platform, refer to the appropriate Targeting manual that 
comes with CodeWarrior Professional. For example, to learn and 
develop an application or DLL for Win32/Intel using CodeWarrior, 
read Targeting Win32.

Framework Target platform

AWT (Abstract Windowing Toolkit) Java

Swing Java

MFC (Microsoft Foundation Classes) Windows

PowerPlant Mac OS
QSP–16 QuickStart Professional
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CodeWarrior Documentation
Every Targeting manual has the following:

• a description of the tools you’ll use to develop software for        
the target platform it covers 

• a tutorial project

• steps to configure different kinds of projects for the platform 

• relevant libraries and other useful information

Getting printed documentation

Some manuals titled Inside CodeWarrior are available as printed 
books. Contact your local distributor or browse the Metrowerks 
Web page (http://www.metrowerks.com/geekware/ ) for 
information.

Example Projects

CodeWarrior Professional comes with lots of sample source code 
and projects to give you an insight into how others use 
CodeWarrior to develop software. You’ll find this sample software 
in the CodeWarrior Examples  folder on your CodeWarrior CD.
QuickStart Professional QSP–17 
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3
Windows ® Installation and 
Programming of 
CodeWarrior ®

This chapter explains the installation procedure for the 
CodeWarrior Professional software package on PCs running 
Windows®. The chapter also provides you with an example 
program to create a simple console application using CodeWarrior. 
The topics in this chapter are:

• Windows System Requirements

• Windows Installation Procedure

• Creating a Windows Application

Windows System Requirements
The CodeWarrior IDE requires the following hardware and 
software:

Table 3.1 Windows Requirements

Hardware Intel® Pentium® or AMD K6 –class microprocessor, 
32 megabytes of RAM, CD-ROM drive

Software Windows NT 4.0 or greater (recommended) or 
Windows 95 or later

Other 90 MB free hard disk space (minimum install), 
450 MB for a full install
QuickStart Professional QSP–19 



Windows® Instal lat ion and Programming of  CodeWarr ior®
Installation Overview on Windows
Installation Overview on Windows
The installation software on the CodeWarrior Professional Windows 
Tools CD-ROM installs all the necessary components you will need 
to use CodeWarrior. 

Before You Install

Before installing the software on your Windows computer, you 
should:

Figure 3.1 Metrowerks installation options

1. Read the CodeWarrior/Metrowerks Software License.

Make sure you understand and agree with the “Metrowerks 
Software License Agreement” on page 85 before installing the 
software.

2. Make sure your software package is complete.

This software package should contain:

1. QuickStart Professional guide (optional on some products)
QSP–20 QuickStart Professional
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2. A CodeWarrior Professional Windows Tools CD

3. A CodeWarrior Professional Reference CD

4. A registration card

5. Geekware catalog

NOTE If any of these items are missing, contact your local distributor or 
Metrowerks sales (sales@metrowerks.com ). See “Metrowerks 
Support” on page 79 for more information.

3. Make sure your computer system meets the specified hardware 
and software requirements.

See “Windows System Requirements” on page 19.

4. Quit all running applications before installing.

To avoid installation problems, it is highly recommended that you 
quit all running applications before launching the CodeWarrior 
installation software.

WARNING! Be sure to turn off all virus protection software before running the in-
stallation software.
QuickStart Professional QSP–21 
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Windows Installation Procedure

To install CodeWarrior Professional on a computer running Windows:

1. Back up and remove previous versions of CodeWarrior.

The installation software on CodeWarrior Professional can’t 
successfully install a new version of CodeWarrior if an older version 
of CodeWarrior already exists on your computer. To remove the old 
version of CodeWarrior, launch the Uninstall CodeWarrior 
program. This program is available from the Start menu.

2. Launch the CodeWarrior installation program.

Insert the CodeWarrior Professional Windows Tools CD into your CD-
ROM drive.

If the Auto Insert Notification setting for your CD-ROM drive is 
enabled, a dialog box will appear automatically when the CD is 
inserted or when you double-click the CD icon. Click Launch 
CodeWarrior Setup to begin installing CodeWarrior.

Alternately, double-click the CD icon, then double-click the file 
named Setup.exe  in the CD’s top folder to begin installing 
CodeWarrior.

In a moment a window appears, welcoming you to CodeWarrior 
Setup. Click Next to continue to the software license.

TIP You can click Cancel anytime during the setup process to stop the 
installation and exit the installation program.

3. Read and agree to the software license.

When the software license appears, please read it. If you agree to its 
terms, click Yes to continue installation. If you do not agree, click No 
to exit the setup program.

4. Read the installation notes.

When the installation note appears, please read it for any last 
minute information on this release. Click Yes to continue.

5. Set your CodeWarrior options.

The CodeWarrior Installer will now walk you through a series of 
dialogs, asking questions to determine what should be installed, 
where it should be installed, and various other installation options 
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before installation begins. Just follow along, answering the 
questions until you reach the summary window.

6. Review your choices.

Review all your installation choices. If you aren’t satisfied, use the 
Back button to make changes. Otherwise, click Next to start the 
install operation. The Setup.exe  program installs the chosen 
CodeWarrior components on your hard disk. You are required to 
Restart your computer at this point.

7. After installation, read the release notes.

After installation, please read the file “What’s New” for the latest 
release information, and refer to the Release  Notes  directory for 
additional release details. For information on CodeWarrior’s Y2K 
compliance, please read the note on “CodeWarrior Year 2000 
Compliance” on page 10.

8. Install CodeWarrior documentation and examples.

Repeat steps 1 through 8 using the CodeWarrior Professional Reference 
CD to install the CodeWarrior documentation, programming 
examples, third-party books, and other programming goodies.

TIP Some of the documentation on the Reference CD exists in uncom-
pressed format to allow direct viewing on the CD.

9. Install a browser.

A browser, like Microsoft Internet Explorer (MSIE) is required to 
access the HTML documentation. If you don’t already have a 
browser on your hard disk, the MSIE installer can be found in the 
Documentation\Viewers  folder on the CodeWarrior Professional 
Reference CD.

10. Install Adobe Acrobat.

To read the PDF documentation, Adobe’s Acrobat Reader must be 
installed on your hard disk. If you don’t already have Acrobat on 
your hard disk, launch its installation software in the 
Documentation\Viewers  folder on the CodeWarrior Professional 
Reference CD.
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What’s Installed

Once the installation software is finished, you will have a 
Metrowerks  folder installed on your hard disk. Inside will be all 
the components you chose during installation. See the 
documentation for information on what has been installed.

Creating a Windows Application
With CodeWarrior up and running on your PC, follow the steps 
below to create a simple console application.

1. Choose the File➔New menu item.

A New window appears.

2. Select the "C Console App" stationery.

The filename is highlighted.

3. Enter project name.

Type in a project name (we used Test.mcp ) and give it the .mcp 
extension. This enables the IDE to recognize the project as a 
CodeWarrior project. 

4. Select the location to save the project. 

5. Click OK.

The New Project window closes and the Name New Project As 
window appears

NOTE Enable the Create Folder  box in the New Project  window to create 
a new folder for your project in the selected location

6. Click Save.

The Name New Project As window closes and a new project based 
upon the chosen stationery is created.

7. Choose the File➔New menu item. 

A new empty editor window opens. 
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8. Choose File➔Save.

The Save  dialog box appears. Name the source file as Hello.c  and 
click Save. The .c  extension enables the CodeWarrior IDE to 
recognize it as a source code file.

9. Enter  the example code.

/* hello.c */
#include <stdio.h>
main(){

printf("Hello Metrowerks\n”);
return 0;

}

NOTE A hello.c file exists in the new project. Please ignore the existing file 
and proceed with the steps to create a new file with the example 
code.

10. With the editor window frontmost, choose Project➔Add Window.

The Add Files window appears. Use this window to specify which 
build targets should use the Hello.c  file.

11. Click OK.

The Hello.c  file is added to all build targets in the project window.

12. Select main.c  in the project window.

The main.c  filename is highlighted.

13. Choose Project➔Removing Selected Items.

The main.c  file is removed from the window.

14. Choose Project➔Run.

The console project is compiled, linked, and run (Figure 3.2).
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Figure 3.2 Console output for Windows.

Congratulations! You just created a program using the CodeWarrior 
IDE on Windows. For information on programming resources, 
please refer to “CodeWarrior Documentation” on page 71.
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Mac® Installation and 
Programming of 
CodeWarrior ®

This chapter explains the installation procedure for the 
CodeWarrior Professional software package on Mac® computers. 
The chapter also provides you with an example program to create a 
console application using CodeWarrior. The topics in this chapter 
are:

• Mac System Requirements

• Installing CodeWarrior on Mac

• Creating a Mac Application

Mac System Requirements
 CodeWarrior requires the following hardware and software setup.

Table 4.1 Mac requirements

Hardware PowerPC (recommended) or MC68040 processor, 32 
megabytes of RAM, a CD-ROM drive

Software Mac OS System 8.1 or later, 68K-based Mac OS 
computers require CFM 68K Enabler 4.0 (provided 
by the CodeWarrior installation software for system 
software before Mac OS 8)

Other 120 MB free hard disk space (minimum install), 
400 MB for a full install
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Installing CodeWarrior on Mac
The installation software on the CodeWarrior Professional Mac Tools 
CD-ROM installs all the necessary components you need to use 
CodeWarrior. The installation software presents the options listed 
in Table 4.2.

Table 4.2 Installation options for Mac

This option… Installs these items on your hard disk

Full Mac Install all CodeWarrior development tools, 
compilers, linkers, libraries, and help files for 
developing software for Mac OS

Full Java Install all CodeWarrior development tools, 
compilers, linkers, libraries, and help files for 
developing software for Java™ VM (Virtual 
Machine)

Win32/x86 Install all CodeWarrior development tools, 
compilers, linkers, libraries, and help files for 
developing software for the Microsoft® 
Win32 API running on Intel®-compatible x86 
processors

Academic 
Minimal Install 
for 68K

only essential CodeWarrior development 
tools, compilers, linkers, libraries, and help 
files for developing software for Mac OS 68K

Academic 
Minimal Install 
for PPC

only essential CodeWarrior development 
tools, compilers, linkers, libraries, and help 
files for developing software for PPC

Custom Options Enables you to customize installation and 
choose options based on project 
requirements.
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Before You Install

Before installing the software on your Mac OS computer, you 
should:

1. Read the CodeWarrior Software License.

Make sure you understand and agree with the “Metrowerks 
Software License Agreement” on page 85 before installing the 
software.

2. Make sure your software package is complete.

This software package should contain:

1. QuickStart Professional guide (optional on some products)

2. A CodeWarrior Professional Mac OS Tools CD

3. A CodeWarrior Professional Reference CD

4. A registration card

5. Geekware catalog

NOTE If any of these items are missing, contact your local distributor or 
Metrowerks sales (sales@metrowerks.com ). See “Metrowerks 
Support” on page 79 for more information.

3. Make sure your computer system meets the specified hardware 
and software requirements.

See “Mac System Requirements” on page 27.

4. Quit all running applications before installing.

To avoid installation problems, it is highly recommended that you 
quit all running applications before running the Metrowerks 
software installer.
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Figure 4.1 CodeWarrior installer options

WARNING! Be sure to turn off all virus protection and file sharing before running 
the installer.

TIP To get more information about an option, click the  button to the 
item’s right. A dialog will appear displaying the option’s size and 
content.

Mac Installation Procedure

To install CodeWarrior Professional on your Mac computer:

1. Launch the CodeWarrior installation software.

Insert the CodeWarrior Professional Mac OS Tools CD-ROM into your 
CD-ROM drive and wait for the CD’s icon to appear on the 
computer’s desktop.

Double-click on the CD’s icon. Then double-click the file named 
CWPro 5 Tools Installer  in the CD’s top folder to launch the 
application and display the welcome screen.

Click Continue to display the software license for CodeWarrior 
Professional.
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2. Read the software license.

If you agree with the license, click Accept to display the release 
notes message.

3. Read the release notes.

When the release notes appear, please read them. Then click 
Continue to display the options window.  For information on 
CodeWarrior’s Y2K compliance, please read the note on 
“CodeWarrior Year 2000 Compliance” on page 10.

4. Select a destination for the files.

Choose location to install CodeWarrior on your hard disk using the 
Install Location popup menu (Figure 4.2).

Figure 4.2 Install Location

Choose the Select Folder from the popup menu to install to a 
specific folder on the currently selected disk drive. Click Switch 
Disk to choose the next available disk drive.

5. Choose your installation options.

See “Installing CodeWarrior on Mac” on page 28 for descriptions of 
the installable items. After choosing the components to place on 
your computer, click Install. The CodeWarrior installation process 
may take several minutes.

6. After installation, read the release notes.

If the installation software recommends restarting your computer, 
do so to make sure any system extensions are properly initialized 
before using CodeWarrior. Then please read the file “What’s New” 
for the latest release information, and refer to the CW Release  
Notes  folder for additional release details.

7. Install CodeWarrior documentation and examples.

Repeat steps 1 through 6 using the “CWPro Reference Installer” 
application on the CodeWarrior Professional Reference CD to install the 
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CodeWarrior documentation, programming examples, third-party 
books, and other programming goodies.

TIP Some of the documentation on the exists in uncompressed format to 
allow direct viewing on the CD.

8. Install Microsoft Internet Explorer.

A browser, like Microsoft Internet Explorer (MSIE) is required to 
access the HTML documentation. If you don’t already have a 
browser on your hard disk, the MSIE installer can be found in the 
Documentation:Viewers  folder on the CodeWarrior Professional 
Reference CD.

9. Install Adobe Acrobat.

To read the PDF documentation, Adobe’s Acrobat Reader must be 
installed on your hard disk. If you don’t already have Acrobat on 
your hard disk, launch its installation software in the 
Documentation:Viewers  folder on the CodeWarrior Professional 
Reference CD.

What’s Installed

Once the installation software is finished, you will have a 
Metrowerks  folder installed on your hard disk. Inside will be all 
the components you chose during installation. See the 
documentation for information on what has been installed.

Creating a Mac Application
With CodeWarrior up and running on your Macintosh, follow the 
steps below to create a simple console application.

1. Choose File➔New Project.

The New Project window and a list of options appear.

2. Click the triangle on the left.

A submenu appears with a sub-stationery list.
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3. Select "Std C Console Multi-Target" from the stationery list.

The "Std C Console Multi-Target" stationery is located in the 
MacOS–>C_C++->Standard Console  folder. Use the disclosure 
triangles to view the contents of the stationery subfolders.

4. Click OK.

The Name New Project As window appears.

5. Enter the project name.

Type in a project name and give it the .mcp extension. This enables 
the IDE to recognize the project as a CodeWarrior project. Also, use 
the standard navigation controls to specify the folder where the 
project file should be saved. 

6. Click Save.

The Name New Project As window closes and a new project based 
upon the chosen stationery is created.

7. Choose File ➔New.

A new empty editor window appears.

8. Enter  the example code.

In the empty editor window, enter the following source code:

/* hello.c */
#include <stdio.h>
main() {

printf("Hello Metrowerks\n");
return 0;

}

NOTE A hello.c file exists in the new project. Please ignore the existing file 
and proceed with the steps to create a new file with the example 
code.

9. Choose File ➔Save.

The Save dialog box appears. Name the source file Hello.c  and 
click Save. The .c  extension enables the CodeWarrior IDE to 
recognize it as a source code file.
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10. With the editor window frontmost, choose Project➔Add Window.

The Add Files window appears. Use this window to specify which 
build targets should use the Hello.c  file.

11. Click OK.

The Hello.c  file is added to all build targets in the project window.

12. Select Helloworld.cp  in the project window.

The Helloworld.cp  filename is highlighted.

13. Choose Project➔Removing Selected Items.

The Helloworld.cp  file is deleted.

14. Choose Project➔Run.

The project is compiled, linked, and run (Figure 4.3).

Figure 4.3 Console output for Mac.

Congratulations! You just created a program using the CodeWarrior 
IDE on your Mac. For information  on programming resources, 
please refer to “CodeWarrior Documentation” on page 71.
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Solaris ™ Installation and 
Programming of 
CodeWarrior ®

This chapter explains the CodeWarrior Professional system 
requirements for operating on Sun™ Solaris™, how to install the 
CodeWarrior software, and walks you through the creation of a 
console application. The topics in this chapter are:

• Solaris System Requirements

• Installing CodeWarrior on Solaris

• Creating a Solaris Application

Solaris System Requirements
The CodeWarrior IDE requires the following hardware and 
software:

Table 5.1 Solaris Requirements

Hardware Sparc-based machine, at least 64 megabytes of 
RAM, CD-ROM drive

Software Solaris version 2.5.1 or later, an X11-R5 server or 
later, a CDE window manager that is vX11-r5 or 
later, Motif 1.2 or later

Other 80 MB free hard disk space
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Installing CodeWarrior on Solaris
The installation software on the CodeWarrior Professional Solaris 
CD-ROM installs all the necessary components you will need to use 
CodeWarrior. The installation software presents the options listed 
in Table 5.2.

Table 5.2 Installation types for Solaris

Before You Install

Before installing the software on your computer, you should:

1. Read the CodeWarrior/Metrowerks Software License.

Make sure you understand and agree with the “Metrowerks 
Software License Agreement” on page 85 before installing the 
software.

2. Make sure your software package is complete.

This software package should contain:

1. QuickStart Professional guide (optional on some products)

2. A CodeWarrior Professional Solaris Tools CD

3. A registration card

4. Geekware catalog

This option… Installs these items on your hard disk

CodeWarrior  IDE 
& Java Support

all CodeWarrior development tools, 
compilers, linkers, libraries, and help files, 
as well as the Sun JDK version 1.1.6 and 1.2

GCC 2.8.1
Support

configures the IDE for GCC 2.8.1 (which 
must be previously installed)

CodeWarrior
Documentation

documentation on functions and features 
the CodeWarrior IDE and using the IDE to 
write code for the Java VM on Solaris

CodeWarrior
Examples

a set of example CodeWarrior projects and 
tutorials
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NOTE If any of these items are missing, contact your local distributor or 
Metrowerks sales (sales@metrowerks.com ). See “Metrowerks 
Support” on page 79 for more information.

3. Make sure your computer system meets the specified hardware 
and software requirements.

See “Solaris System Requirements” on page 35.

Solaris Installation Procedure

To install CodeWarrior Professional:

1. Launch the CodeWarrior installation program.

Insert the CodeWarrior Professional Solaris CD-ROM into your CD-
ROM drive.

The installer program can be found in the following directory: /
cdrom/cwpro_solaris/ . Open a terminal window and run the 
installer like so:

cd /cdrom/cwpro_solaris 
./install-sh

The installer will display a welcome message. Read it and press 
space to continue. However,  you must first ensure you have 
“write” privileges.

The installer will check your environment to verify that it is 
compatible, and notify you if any incompatibilities are found. Type 
“y” (without the quotes) to continue once the check is complete.

TIP You can type “q” (without the quotes) at most prompts during the 
setup process to stop the installation and exit the installation pro-
gram.

2. Read the software license.

When the software license appears, please read it. If you agree, type 
“y” when you are asked if you accept the terms of the agreement.
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3. Select destination for the files.

By default, the installer will set the install path to /usr/local . If 
you would like to install to another directory, type “n” to this 
prompt. Otherwise, type “y” to continue.

4. Choose components to install.

See “Installing CodeWarrior on Solaris” on page 36 for a description 
of components that can be installed with this installer. The installer 
will ask you whether you want to install each one of these 
components. Type “y” to install a component, or “n” to skip it. 

NOTE If you choose to install GCC support, the installer will ask you to lo-
cate the GCC directory at this point.

5. Review your choices.

The installer will list the components you selected, and ask you if 
this is correct. Type “y” to continue, or “n” to make changes.

6. After installation, read the release notes.

After installation, please read the release notes for the latest release 
information. For information on CodeWarrior’s Y2K compliance, 
please read the note on “CodeWarrior Year 2000 Compliance” on 
page 10.

7. Install Adobe Acrobat.

To read CodeWarriors documentation, you must have Adobe 
Acrobat Reader installed on your system.  Open the 
Documentation_Viewers  directory in the cdrom  directory and 
untar the acrdsrch_solaris_301.tar.gz  file to install Acrobat 
Reader.

What’s Installed

Once the installation software is finished, you will have a cwpro4  
directory installed on your system. Inside will be all the components 
you chose during installation. See INSTALL.LOG  for information on 
what has been installed.
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Creating a Solaris Application
Follow these steps to create a simple console application.

1. Choose File ➔New Project.

The New Project dialog box appears.

2. Click the expansion control next to C_C++

The C_C++ group opens.

3. Click C to select the C stationery.  

4. Click  OK.

The File Save dialog box appears.

NOTE Check the Create Folder  box in the New Project  window to create 
a new folder for your project in the selected location

5. Enter the project name. 

Type in a project name and give it file extension .mcp (we used 
test.mcp). This enables the IDE to recognize the project file as a 
CodeWarrior project.

6. Use the standard navigation controls to specify and save the new 
project. 

7. Click Save.

The File Save window closes and a new project based on the chosen 
stationery is created.

8. Choose File ➔New.

A new empty editor window opens.  

9. Choose File ➔Save.

The File Save dialog box appears. Name the file HelloWorld.c and 
click Save. The .c extension enables the IDE to recognize this file as a 
source code file.
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10. Enter the sample code:

/* helloworld.c */
#include <stdio.h>
int main(void){

printf("Hello  world,  this  is  CodeWarrior!\n");
return 0;

}

NOTE A hello.c  file exists in the new project. Please ignore the existing 
file and proceed with the steps to create a new file with the example 
code.

11. Select the Sources group in the project window

The Sources group is highlighted. 

12. With the editor window frontmost, choose Project➔Add Window.

The HelloWorld.c  file is added to the project window. 

13. Select the file named "hello.c" in the project window

The hello.c  file is highlighted. 

14. Choose Project➔Remove Selected Items.

The hello.c  file is removed from the project window.

15. Choose Project➔Build .

The project is compiled and the executable is built. 

16. Run the executable. It is named "a.out", and is in the same folder 
as the project. 

The executable runs and the console output appears (Figure 5.1).

NOTE This must be run from a terminal window or the File Manager. 
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Figure 5.1 Console output for Solaris

Congratulations! You just created a program using the CodeWarrior 
IDE on Solaris. For information  on programming resources, please 
refer to “CodeWarrior Documentation” on page 71.
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Linux Installation and 
Programming of 
CodeWarrior ®

This chapter explains the CodeWarrior Professional  for Linux 
system requirements, how to install the CodeWarrior software, and 
walks you through the creation of a console application. The topics 
in this chapter are:

• Linux System Requirements

• Installing CodeWarrior on Linux

• Creating a Linux Application

Linux System Requirements
The CodeWarrior IDE requires the following hardware and 
software:

Table 6.1 Linux Requirements

Hardware Intel® Pentium® or AMD K6®–class microprocessor, 
at least 64 megabytes of RAM, CD-ROM drive

Software Red Hat® Linux for x86 version 5.2 or later, an X11-
R5 display server

Other 40 MB free hard disk space
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Installing CodeWarrior on Linux
The installation software on the CodeWarrior Professional for Linux 
CD-ROM installs all the necessary components you will need to use 
CodeWarrior. 

There are a couple things you should be aware of before running the 
CodeWarrior install script. This section discusses the following 
topics:

• Metrowerks Software License

• Software Package Contents

• EGCS for C++ Development

• About DDD

• Installing CodeWarrior

Metrowerks Software License
Make sure you understand and agree with the software license be-
fore installing the software. The software license can be found on 
the root level of the CodeWarrior CD, in a file named LICENSE.

Software Package Contents

This software package should contain:

1. QuickStart Professional guide (optional on some products)

2. A CodeWarrior Professional CD-ROM

3. A registration card

4. Geekware catalog

NOTE: If any of these items are missing, contact your local dis-
tributor or Metrowerks sales (sales@metrowerks.com ).
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EGCS for C++ Development

The stock Red Hat 5.2 C/C++ development installation does not 
contain everything needed to do C++ development with 
CodeWarrior. If you wish to use CodeWarrior for C++ 
development, you need to build and install your own copy of GCC 
or EGCS. It is best if this is done before you run the CodeWarrior 
install script. If you install EGCS after you have installed 
CodeWarrior, you will need to run the config_gcc_links.sh script 
manually so that CodeWarrior will be able to use it. 

NOTE This process will not remove the copy of gcc that is installed into /
bin  in the stock RedHat install.

In the Third_Party  directory you will find the EGCS archive 
named egcs-1.1.2.tar.gz . Following are brief instructions on 
how to install it. 

NOTE You will likely need to be root  for step three to work correctly.

1. Copy and decompress the archive.

Copy the egcs-1.1.2.tar.gz  archive to your hard drive from the 
Third_Party  directory on the CodeWarrior CD and decompress 
the archive.

2. Create the EGCS build directory.

Create a directory at the same level as the decompressed files called 
egcs-linux-build  (or something similar).

3. Configure and install egcs.

cd  to the build directory and enter the following commands:

./egcs-1.1.1/configure --enable-shared
make bootstrap
make install

The two make steps will take some time. EGCS will be installed in /
usr/local . Make sure that /usr/local  comes before /bin  in 
your PATH environment variable so that CodeWarrior finds the 
correct version of gcc. Typing which gcc  or gcc -v  after 
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installation is complete will help you verify that CodeWarrior will 
find the correct version of gcc.

The latest EGCS C/C++ development releases can be found here:

ftp://egcs.cygnus.com/pub/egcs/releases

For more info about egcs  see:

http://egcs.cygnus.com/

About DDD

We have included ddd , a visual front-end to the popular debugger, 
gdb . The ddd  package is an optional install, and is not required by 
CodeWarrior to operate. However, the tutorial in this manual 
shows ddd  windows. So, you may want to install ddd  before taking 
the tutorial.

NOTE You will likely need to be root  for rpm to work correctly.

Copy the ddd-static-3.1.3-1.i386.rpm  file to your hard drive 
from the Third_Party  directory on the CodeWarrior CD and type 
the following command:

rpm -i ddd-static-3.1.3-1.i386.rpm

To use ddd  in your projects, see the section on third party 
debuggers under in the Targeting Linux manual.

Installing CodeWarrior

The CodeWarrior installer is a script named install-sh  that 
installs the CodeWarrior IDE, and optionally the documentation 
and example projects. After installation is complete, a configuration 
script named config_gcc_links.sh  creates soft links in 
CodeWarrior’s directory that point to the directories that the gcc 
compiler looks in to find system header files.

Perform the following steps to install CodeWarrior onto your Linux 
system:
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1. Launch the CodeWarrior installation program.

Insert the CodeWarrior Professional CD-ROM into your CD-ROM 
drive.

The install script can be found in root directory of the CodeWarrior 
Professional CD-ROM. Open a terminal window, cd to the directory 
you mounted the CD in, and run the installer like so:

./install-sh

TIP: You can type “q” (without the quotes) at most prompts dur-
ing the setup process to stop the installation and exit the installa-
tion program.

2. Read the software license.

The install script uses more  to display the Metrowerks Software Li-
cense. When the software license appears, please read it. If you 
agree, type “y” when you are asked if you accept the terms of the 
agreement.

3. Choose components to install.

There are two components that can be installed with this installer: 
the CodeWarrior IDE, and the CodeWarrior documentation and ex-
amples. The installer will ask you whether you want to install each 
one of these components. Type “y” to install a component, or “n” to 
skip it. 

4. Select destination for the files.

By default, the installer will set the install path to /usr/local . The 
installer will ask you if you would like to change the installation 
directory. If you would like to change it, type “y”; otherwise, type 
“n” to continue.

If you answered "y", the installer will ask you to specify the full path 
of the directory into which you would like CodeWarrior to be 
installed.

5. After installation, read the release notes.

After installation, please read the release notes for the latest release 
information. 
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6. Install Adobe Acrobat.

CodeWarriors documentation is provided in both postscript format 
and acrobat PDF format. To view the acrobat PDF format, you must 
have Adobe Acrobat Reader installed on your system. Open the 
Documentation_Viewers  directory in the CD-ROM directory and 
untar the arobat.reader.3021.installer.tar  file to install 
Acrobat Reader.

To launch CodeWarrior you execute the cwide script found in the 
following location:

metrowerks/CodeWarrior3.3/

You may wish to place a softlink to this script in a directory in your 
PATH.  For example:

ln -s /usr/local/metrowerks/CodeWarrior3.3/cwide 
/usr/local/bin/cwide

This way you can launch the IDE with the simple command: cwide  
from any terminal.

See the INSTALL  readme file on your CodeWarrior Professional CD-
ROM for more information.

What’s Installed on Linux

Once the installation software is finished, you will have a cwpro  
directory installed on your system. Inside will be all the components 
you chose during installation. See INSTALL.LOG  for information on 
what has been installed.
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Creating a Linux Application
Follow these steps to create a simple console application.

1. Choose File ➔New Project.

The New Project dialog box appears.

2. Click the expansion control next to C_C++.

The C_C++ group opens.

3. Select C to select the C stationery.  

4. Click  OK.

The File Save dialog box appears.

NOTE Check the Create Folder  box in the New Project  window to create 
a new folder for your project in the selected location

5. Enter the project name. 

Type in a project name and give it file extension .mcp (we used 
test.mcp). This enables the IDE to recognize the project file as a 
CodeWarrior project.

6. Use the standard navigation controls to specify and save the new 
project. 

7. Click Save.

The File Save window closes and a new project based on the chosen 
stationery is created.

8. Choose File➔New.

A new empty editor window opens.  

9. Choose File➔Save .

The File Save dialog box appears. Name the file HelloWorld.c  
and click Save. The .c  extension enables the IDE to recognize this 
file as a source code file.
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10. Enter the sample code:

/* helloworld.c */
#include <stdio.h>
int main(void){

printf("Hello  world, this is CodeWarrior!\n");
return 0;

}

NOTE A hello.c  file exists in the new project. Please ignore the existing 
file and proceed with the steps to create a new file with the example 
code.

11. Select the Sources group in the project window

The Sources group is highlighted. 

12. With the editor window frontmost, choose Project➔Add Window.

The HelloWorld.c  file is added to the project window. 

13. Select the file named "hello.c" in the project window

The hello.c  file is highlighted. 

14. Choose Project➔Remove Selected Items.

The hello.c  file is removed from the project window.

15. Choose Project➔Build.

The project compiles and the executable built. 

16. Run the executable. It is named "a.out", and is in the same folder 
as the project. 

The executable runs and the console output (shown in Figure 6.1) 
appears.

NOTE This must be run from a terminal window or the File Manager. 
QSP–50 QuickStart Professional



Linux Instal lat ion and Programming of  CodeWarr ior®
Creating a Linux Application
Figure 6.1 Console output for Linux

Congratulations! You just created a program using the CodeWarrior 
IDE on Linux. For information  on programming resources, please 
refer to “CodeWarrior Documentation” on page 71.
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7
A Quick Tour of 
CodeWarrior

This short tour gives new users a glimpse of the CodeWarrior 
Integrated Development Environment (IDE). 

Guided Tour Overview
The CodeWarrior IDE is the center of CodeWarrior software 
development. From the IDE you edit, browse, compile, link, debug, 
and do many other programming tasks.

In this quick tour, you’ll learn to do these tasks while working on an 
example project, gnu_go.mcp :

• Launching the CodeWarrior IDE

• Setting IDE Preferences

• Opening a CodeWarrior Project

• Using the Project Window

• Using the CodeWarrior Editor

• Target Settings Options

• Building Projects with CodeWarrior

• Where to Go From Here
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Launching the CodeWarrior IDE
In this section you learn how simple it is to launch the CodeWarrior 
IDE, thereby opening the gateway to a powerful set of 
programming tools and beginning your career as a code warrior.

Before you can begin learning about the CodeWarrior IDE, you’ll 
need to launch it.

Windows Click the Start button in the Task bar, choose Programs, choose 
CodeWarrior Pro5, then choose the CodeWarrior IDE item. 

NOTE The CodeWarrior IDE item will be in a different place in the Start 
menu if you didn’t use the Start menu default setting while installing 
CodeWarrior.

Mac OS Double-click the CodeWarrior IDE icon in the Metrowerks 
CodeWarrior  folder. The CodeWarrior IDE application launches, 
and its menu bar appears at the top of the screen.

Solaris /Linux Type cwide  in any terminal window. An action/run dialog box 
appears. Click OK. The IDE is launched on a Run terminal window. 

NOTE This procedure of launching the IDE on Solaris assumes that the 
CodeWarrior directory has been included in your path.

The next section shows you how to customize the IDE.
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Opening a CodeWarrior Project
Open a project file in exactly the same way you open any other file 
from within an application on your computer. In this step you open 
the gnu_go.mcp  project file.

NOTE The gnu_go.mcp  project is stored on the CD in compressed form, 
either as a  .zip  (Windows) or a .sit  (Mac) file. You will need to 
uncompress the archive associated with your platform to use the 
project files.

A project is a collection of files and settings that the IDE’s compilers 
and linkers use to create a program or other piece of software.

To open a project choose the File➔Open menu item to display a file 
dialog box. Then locate and select the gnu_go.mcp  project file and 
click Open. This file is in the CodeWarrior  Examples  folder in the 
CoreTutorials  folder on the CodeWarrior Professional Reference 
CD.

The IDE opens the project file and displays a Project window.

Now that you have a project open, let’s explore the features of the 
Project window.

Using the Project Window
To effectively use the CodeWarrior IDE, you should be familiar 
with the Project window. The window displays lots of information 
about a project, so identifying and understanding that information 
is our next step. The Project window has these items:

• View Tabs

• Toolbar

• Project Window Columns

• Groups

• Interface Pop-ups

• Context Pop-ups
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View Tabs

The Project window uses view tabs to present different faces of 
information in the project. Click a view tab to change the 
information displayed in the Project window.

Figure 7.1 View tabs in the project window

The Project window uses these view tabs:

• Files—enables you to inspect file information in a project. 

• Design - enables you to create and use mutliple designs for a 
project. Please see the IDE User Guide for a detailed description 
of RAD features.

• Link Order/Segments—enables you to specify the order in 
which files are compiled. 

• Targets— enables you configure the targets a project will build 
and the order in which the targets are built.

NOTE The Link Order view sometimes has a different name. For example, 
when working with Mac OS 68K projects, the Link Order view be-
comes the Segment view and in embedded projects it displays as 
Overlays.

Toolbar

The Toolbar shows icon buttons that correspond to CodeWarrior 
IDE commands and functions. 
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Figure 7.2 The default toolbar in the Project window

The toolbar appears in two formats:

• Window Toolbar—present in several windows within 
CodeWarrior, including the Project window. An example 
appears in Figure 7.2.

• Floating Toolbar—appears as a floating palette that may 
optionally be anchored under the IDE’s menu bar. 

For information on customizing, hiding, and showing toolbars, see 
the IDE User Guide.

Toolbar Tooltips

Use Tooltips to identify a button in a toolbar. 

Windows To view a Tooltip, position the mouse pointer over the button 
without moving it for a moment.

Mac OS To view a Tooltip, press the Control key and position the mouse 
pointer over a toolbar button.

Solaris/Linux Toolbar Tooltips are currently unavailable for Solaris.

The Tooltip appears, describing the icon underneath the mouse 
pointer (Figure 7.3).
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Figure 7.3 Viewing a Tooltip (on Windows)

Project Window Columns

The columns that appear in the Project window’s File view are listed 
in the following table.

Table 7.1 Columns in the Project window

This column… presents this information

 
The Touch column indicates whether a file 
needs to be compiled.

The File column identifies the names of files 
and groups in the project.

The Code column shows the size of the 
compiled executable code.

The Data column shows the size of non-
executable data.

The Target column indicates whether an item 
is in the project’s current target.

The Debug column indicates whether 
debugging information will be generated for 
an item.
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Groups

Groups in the File view provide a way to organize project files into 
logical categories to help you keep track of your files. Groups do not 
affect the binary code produced by the compilers, only the 
organization of files within the Project window. Groups can be 
expanded to display their contents, collapsed to hide their contents, 
rearranged, added, and deleted from a project.

TIP Groups in the Link Order New/Segments view might have an ef-
fect on how object code is arranged in your program. Please refer 
the appropriateTargeting manual for the platform specific details 

Interface Pop-ups

Interface Pop-ups reveal additional information about the group or 
files associated with it. The two types of interface pop-ups are:

• Group’s Interface Pop-up—displays a list of all files in that 
group.

• File’s Interface Pop-up—displays a list of interface files required 
to compile the file, and allows you to “touch” the file which 
forces it to recompile on the next update or make operation.

To view an Interface pop-up click on the pop-up menu to the 
extreme right of the file or group name. The file or group interface 
pop-up appears. Please refer to Figure 7.7 on page 64.

The Checkout Status column indicates the 
current status of an item in a version control 
system. This column only appears if a version 
control system is active.

The Link column indicates whether the object 
code generated from an item will be linked 
into the target. This column only appears in 
the Targets view.

This column… presents this information
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Context Pop-ups

The two forms of Context Pop-ups available in the Project window 
include:

• Group Context Pop-up—enables you to check syntax, 
preprocess, precompile, compile, disassemble, or remove it from 
the project.

• File Context Pop-up—does everything the Group Context Pop-
up does as well as showing the File Path, and Reveal in Finder 
the file’s location.

To view a Context Pop-up, position the cursor over a file or group 
name, then click and hold the mouse button down without moving 
the mouse (Macintosh) or right-click(Windows). In a moment the 
File context pop-up appears.

Now that you have a better understanding of the Project Manager, 
let’s move onto the next section on setting preferences.

Setting IDE Preferences
With the CodeWarrior IDE up and running, let’s introduce you to 
the Preferences dialog box. You use the Preferences dialog box to set 
options that apply to all projects with which you will work with in 
the CodeWarrior IDE.

This section shows you how to do these tasks with the Preferences 
dialog box:

• Opening the Preferences Dialog Box

• Viewing and Setting Options in Preference Panel

• Closing the Preferences Dialog Box

Opening the Preferences Dialog Box

To change a preference, the Preferences dialog box must be open. To 
open the Preferences dialog box choose Edit➔Preferences. The 
Preferences dialog box appears on the screen (Figure 7.4)
QSP–60 QuickStart Professional



A Quick Tour of  CodeWarr ior
Setting IDE Preferences
Figure 7.4 .The Preferences dialog box

Let’s take a moment to identify some of the items in the Preferences 
dialog box. 

• IDE Preference Panels list in the Edit menu appears on the left 
side of the window. It shows a list of available preference 
panels. Selecting an item in this list displays its corresponding 
panel on the right side of the window.

• Preference Panel is a subpanel and displays the panel selected 
in the IDE Preference Panels list. Changes made in the panel are 
reflected in all new projects you create afterward. 

NOTE The preference panels are fully discussed in the IDE User Guide in 
the chapters Configuring IDE Options and Configuring Target Op-
tions.

The Preferences dialog box has three buttons that are always 
available to assist you in setting the various preference panel 
options (Figure 7.5).
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Figure 7.5 The Preference window’s buttons

These buttons are:

• Factory Settings button resets the current panel to the default 
settings. Using Factory Settings only affects the current panel’s 
settings.

• Revert Panel button restores the current panel settings to its 
initial state,i.e., when the panel was first opened. Click this 
button if, after making changes to a panel’s options, you decide 
the original settings were just fine.

• Save button commits any changes made in the preference panel. 
Once you’re satisfied with the settings in the panel, click Save to 
commit to the changes. 

Viewing and Setting Options in Preference 
Panel

There are several different preference panels available in the 
Preference Panels list. To set a particular preference, you must 
choose its panel. 

To view a Preference panel, click the panel name in the Preference 
Panel list or use the Up and Down arrow keys to change the 
selection. The selected panel name is highlighted in the Preference 
Panel List and the panel appears to the right of the list.

Closing the Preferences Dialog Box

Once you finish setting your global preferences, just close the 
window. To close the Preferences dialog box, click the Preference 
window’s close box or choose Close from the File menu. The 
Preferences dialog box closes.

Now that you understand the use of the Preferences dialog box, let’s 
explore the process of opening a CodeWarrior project.
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Using the CodeWarrior Editor
The CodeWarrior Editor window is where you will spend most of 
your time creating, editing, and navigating through source code for 
your project. This section introduces you to these editing tasks:

• Creating a New Text File

• Opening a File

• Entering Text into a File

• Saving Changes to a File

Creating a New Text File

To create a new text file, just choose File➔New Text File. A new 
untitled editor window will appear, ready for you to enter, edit, and 
save text or source code.

Opening a File

There are a variety of ways to open a source code or text file from 
within a project.

Opening a file from the Project window

You can open any editable text file listed in the Project window. In 
this step you open the main.c  file from the gnu_go.mcp  project.

To open the main.c  file in the Project window double-click its 
name in the Project window (Figure 7.6).

Figure 7.6 Opening a file from the Project window

The file opens and appears in its own window.
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TIP You can also select a file in the Project window using the arrow keys 
and press the Enter/Return  key to open it.

Opening a file with a group pop-up

You can also open an editable text file within a group by using the 
group pop-up that appears to the right of the group name. To open 
a file from a pop-up menu select the file from a group pop-up in the 
Project window (Figure 7.7). 

Figure 7.7 Opening a file within a group pop-up

The file opens and appears in its own window.

Opening a file from the File menu

You can use this method to open any text file, whether it is included 
in the project or not. In this step you open the file endgame.c  using 
the File menu.

To open the endgame.c  source code file choose File➔Open to 
display a file dialog box. Locate and select the endgame.c  file, then 
click Open. The file appears in its own editor window.

Entering Text into a File

Now that you have a file open in the editor, you can enter text or 
source code. The CodeWarrior Editor operates like a regular text 
editor, with many special features designed to ease navigation that 
are beyond the scope of this short tour.
QSP–64 QuickStart Professional



A Quick Tour of  CodeWarr ior
Target Settings Options
To enter text, position the cursor at the point where you want to 
insert text, click the mouse button to place the insertion point, then 
begin typing. Your keystrokes appear at the insertion point.

Saving Changes to a File

As you modify your source code files, it’s a good idea to save the 
changes to disk to prevent data loss. To save a file choose 
File➔Save. If the file has never been saved before, a file dialog box 
will appear prompting you for a location and a name for the file. 
Click Save when you are done.

The IDE saves the file.

Now that you are comfortable with the IDE’s Editor, it’s time to 
explore the Target Settings dialog box.

Target Settings Options
What is a Target?
Before we begin our Targets tour, let’s get familiar with the term 
‘Target’. The term Target has two distinct meanings in CodeWarrior 
terminology. “Target” refers to either the:
• Platform Target - the particular operating system or micropro-

cessor for which you are writing code. For example, if you 
choose to write code for a particular processor running a desk-
top OS, you are specifying a platform target.

• Build Target - the particular collection of settings and files that 
determine what is in your code, and how your code is compiled 
and linked into the final output. For example, if you choose to 
compile code with certain language features enabled, then you 
change the settings in the build target. If you choose to add or 
remove a file from a particular build, you are changing the build 
target.

The Build Target settings apply only to the current target of the 
current project. Settings in one project or target in a project do not 
affect settings in another project or target. The Build Target Settings 
dialog box appears very similar to the Preferences dialog box, with 
many common features.
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Projects can contain one or more build targets. Every target in the 
project has its own unique settings. For example, you can have a 
debug target and a production target. You use the Build Target 
Settings dialog box to set a target’s options.

This section shows you how to do these tasks with the Target 
Settings dialog box:

• Opening the Target Settings Dialog Box

• Viewing and Setting Options in a Settings Panel

• Closing the Target Settings Dialog Box

Opening the Target Settings Dialog Box

To change a target option, the Target Settings dialog box must be 
open. In this step you open the Target Settings dialog box.

To open the Target Settings dialog box choose Edit➔Target 
Settings. Target will be replaced by the name of the current target in 
the project file. On a PC running Windows for example, the targets 
include: gnu_go  x86 , and go_debug . On the Mac OS the targets 
include: gnu_go  68K, gnu_go PPC , and gnu_go FAT .

The Target Settings dialog box opens on the screen.

TIP You can also double-click a target name in the Targets view to open 
the Target Settings dialog box. 

Viewing and Setting Options in a Settings 
Panel

There are several different settings panels available in the Target 
Settings list. To set a particular target option, you must choose its 
panel.

To view a settings panel, click the panel name in the Target Settings 
list, or use the Up and Down arrow keys to change the selection. 
The selected settings panel appears to the right of the list.

To learn about setting options in settings panels, consult the 
Targeting manual for the platform on which your program will run.
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Closing the Target Settings Dialog Box

Once you finish setting the target options, just close the window. To 
close the Target Settings dialog box click its close box or choose  
File➔Close. The Target Settings dialog box closes.

Now that you can set Target Settings for projects, it’s time to build a 
compiled application from the gnu_go.mcp  project.

Building Projects with CodeWarrior
In this section we’ll introduce you to ways of building a project. 
Among the tasks the IDE provides for compiling, linking, running, 
and debugging your project are:

• Updating a Project

• Making a Project

• Running a Project

• Debugging a Project

• Building a Program

TIP Before using a command in the Project menu to compile or link your 
project, make sure the IDE will operate on the right target by choos-
ing it from the Set Current Target sub-menu in the Project menu.

Updating a Project

Use Project➔Bring Up To Date to compile all modified or 
“touched” files. This process creates object code for compiled files, 
but does not link the code into a binary file.

Making a Project

Use Project➔Make to link a project into a binary file. Make only 
creates binary files on the hard disk, it does not interactively run the 
final application.
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Running a Project

Use Project➔Run to launch the application created by your project. 
If the project type is not an application, the Run command is 
disabled. Run will update and link the code if necessary.

Debugging a Project

Use Project➔Debug to launch the application under control of the 
Debugger. You can then debug your code. Debug will also update 
and link the code if necessary.

Building a Program
In this step you name the output application for the gnu_go.mcp  
project, then compile, link, and run it.

To set the application name

1. Open the Target Settings window.

2. Choose the appropriate target for your platform.

Windows Choose x86 Target in the settings panel list.

Mac OS Choose 68K Target in the settings panel list.

Solaris Choose GNU in the settings panel list.

Linux Choose GNU in the settings panel list. 

3. Select Application from the Project Type pop-up menu.

4. Enter “gnu_go” (without the quotes) in the Output File Name 
field.

5. Click Save.

If an alert box appears asking to re-build the project, click OK.

NOTE The name of Target in the Target Settings dialog box changes de-
pending upon the target chosen in the Project window.
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To build the gnu_go application

With the project information in place, it is now time to actually 
build the project. In this step you build the gnu_go.mcp  project.

Choose Project➔Run. The IDE compiles, links, then launches the 
gnu_go  application. 

Congratulations! You’ve just compiled, linked, and executed an 
application using CodeWarrior.

Where to Go From Here 
The IDE makes many of your programming tasks easier. However, 
not all of the features available in the IDE are covered in this tour. 
To learn how to use other advanced features, see the IDE User Guide, 
which is available on the CodeWarrior Professional Reference CD in 
PDF or HTML format.

For specific information about developing software for a specific 
operating system or processor, refer to its corresponding Targeting 
manual, available on the CodeWarrior Professional Reference CD in 
PDF or HTML format..

For  more information on using CodeWarrior, refer to 
“CodeWarrior Documentation” on page 71.
QuickStart Professional QSP–69 



A Quick Tour of  CodeWarr ior
Where to Go From Here
QSP–70 QuickStart Professional



8
CodeWarrior 
Documentation 

This chapter gives you an insight into the technical diversity of 
CodeWarrior’s documentation. It provides you with information on 
CodeWarriors documentaion resources to help you blend into the 
technical mainstream quickly and easily. The following topics are 
covered in this chapter:

• CodeWarrior Online Help

• Documentation

• Books

• Web Sites of Interest

• Beginner’s Resources

• Factory Updates

CodeWarrior Online Help 
CodeWarrior includes a wealth of online documentation covering 
all aspects of programming. Table 8.1 describes the different kinds 
of CodeWarrior online help and their functions.

• CodeWarrior Platform Specific Online Help

• Cross-Platform Help Solutions 
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CodeWarrior Platform Specific Online Help

The CodeWarrior online help on Windows, Mac OS, and UNIX 
provides core CodeWarrior documentation as well as a task 
oriented approach to learning the IDE. It consists of the following:

• How To Topics - These procedural topics provide simple, easy 
to follow instructions on performing tasks common to using the 
CodeWarrior IDE. For example, Creating a New Project, 
Viewing Variables etc.

• Error Reference - a complete listing of common error messages 
generated by CodeWarrior and their possible solutions.

• Glossary - Consists of terms and their definitions specific to 
CodeWarrior.

• CodeWarrior manuals- Includes complete text of some of 
CodeWarrior’s manuals including User Guides, Targeting 
Manuals, and Reference Manuals . 

You can access online help by using the Help menu in the 
CodeWarrior IDE.

Table 8.1 Online Help Formats

NOTE The types of documentation you receive is specific to your platform.   
Please refer to the Documentation folder on the Reference CD for 
more information.

Format Description

WinHelp
(Windows)

The Help format for Windows. Consists of 
reference manuals, task topics, core manuals, and 
a CodeWarrior specific glossary.

QuickHelp
(Mac OS)

The QuickHelp format on Mac OS consists of the 
same content as WinHelp.

HyperHelp
(UNIX)

HyperHelp format for UNIX consists of the same 
Help content as WinHelp.
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Cross-Platform Help Solutions 

We provide cross-platform online assistance through two of the 
most popular and powerful formats - HTML and PDF. 

Table 8.2 Cross-Platform Help

Documentation
CodeWarrior offers the following kinds of printed documentation. 
You can find the online versions of these manuals in the Doc-
umentation\CodeWarrior  folder on your CodeWarrior CD. 

CodeWarrior Documentation

CodeWarrior documentation is classified as follows:

• QuickStart Manuals

• User Guides

• Targeting Manuals

• Reference Manuals

NOTE CodeWarrior also provides PDFs, HTML, and Online Help versions 
of documentation. Please see CodeWarrior Online Help for more in-
formation.

Cross-Platform Help Type

HTML HTML files are small, fast, and 
provide quick and efficient mode of 
online documentation. 

PDF PDFs are compact and provide 
excellent printing qualities offering a 
near-perfect representation of the 
original.
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QuickStart Manuals 

The QuickStart manual includes the basic information required to 
install and use CodeWarrior, its documentation, a simple tutorial to 
create a C console application, and information on contacting 
Metrowerks for technical support, as well as registering, buying, or  
licensing a product. Please refer to QuickStart Professional for 
desktop products and QuickStart Embedded for CodeWarrior 
embedded products.

User Guides

The User Guides provide information you need to effectively use 
the CodeWarrior software. All common features available in the  
CodeWarrior IDE are documented in its user guide. For example, 
Inside CodeWarrior:IDE User Guide discusses the powerful features of 
the CodeWarrior IDE, its debugger, and RAD (Rapid Application 
Development) in great detail. Please refer to Targeting manuals for 
target specific information.

Targeting Manuals

CodeWarrior offers a wide range of Targeting manuals for several 
platforms. These manuals describe how to use CodeWarrior to 
develop code for a specific platform or processor. Targeting 
manuals also include information about platform-specific features 
that are not found in a common user guide. Table 8.3  lists a few of 
the many targeting manuals we offer.

Table 8.3 Targeting Manuals

Targeting Manuals                        Platform

Targeting Windows Win32/x86
Targeting Mac OS Mac OS
Targeting Java VM Java VM on Windows, Mac,  and 

Solaris
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Reference Manuals

The Reference manuals provide descriptive reference information of 
a language (C/C++/Java/Pascal) or a programming API (MSL, 
PowerPlant, etc). Reference manuals normally apply to all 
CodeWarrior supported platforms. However, there are exceptions. 
While the C, Java, and Pascal reference manuals are all cross-
platform,  PowerPlant Reference is not.

NOTE The online version of the QuickStart, User Guides, Targeting, and 
Reference manuals are located in the \\Documentation\ 
CodeWarrior  folder. Many of the CodeWarrior manuals are also 
available in printed form and can be ordered directly from the 
Metrowerks store. For more information on ordering, see “CodeWar-
rior Factory Store” on page 83.

Partners

To aid your learning curve, CodeWarrior consists of a 
comprehensive set of books and documentation  provided by some 
of our partners in the industry today. While CodeWarrior 
documentation is produced and supported by Metrowerks, the 
third-party documentation is included for your benefit. Please refer 
to the Partner  folder on the Reference CD for a comprehensive set 
of third-party books.

Books

The CodeWarrior CD  also provides additional third party 
programming books written by popular authors that cover 
programming on different platforms and languages supported by 
the CodeWarrior IDE. Please refer to the Books  folder for the list of 
books provided for your convenience.

NOTE These books are available only in PDF format and are provided as a 
service to our users. Due to licensing restrictions these PDF files do 
not allow printing.
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Other References

Table 8.4 lists several third-party books available in your favorite 
local or online bookstore that can assist you in getting up to speed 
on your programming projects.

NOTE For your convenience, the CodeWarrior CD often provides software 
documentation from other companies. Please see the \\Documen-
tation\Other  folder for a list of manuals. The format used in 
these manuals are specific to their company.

Table 8.4 Other programming books of interest

Viewers

For your convenience, CodeWarrior provides documentation 
viewers such as Acrobat Reader, QuickHelp, and Internet Explorer 
with its documentation. Please see the Viewers  folder on the CD  to 
install preferred documentation viewers. 

To learn… Read this book

C New C Primer by Michael Waite and Stephen Prata
Teach Yourself C by Herb Schildt
The C Programming Language, 2nd Edition by B. Kernighan and D. 
Ritchie

C++ C++ Primer Plus, 3rd Edition   by Stephen Prata
Teach Yourself C++ by Herb Schildt
The C++ Programming Language, 2nd Edition by Bjarne Stroustrup.

CodeWarrior Metrowerks CodeWarrior Programming by Dan Parks Sydow
Power Macintosh Programming Starter Kit by Tom Thompson

Win32/x86 Advanced Windows® by Jeffrey Richter
Programming Windows® 95 by Arnold Petzold

Mac OS Macintosh Programming Techniques by Dan Parks Sydow
Macintosh C Programming Primer, Volume 1 by D. Mark & C. Reed
Programming Starter Kit for Macintosh   by Jim Trudeau
Ultimate Macintosh Programming by Dave Mark
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Web Sites of Interest
Programming tools change fast and access to the latest information 
about a particular technology or programming environment is vital. 
Listed below are some of the major Web sites where developer 
information can be obtained:

Table 8.5 Web sites

Beginner’s Resources
Always refer to the CodeWarrior website (www.metrowerks.com) 
for a detailed description and comprehensive listing of printed and 
online books, online tutorials, and additional information on 
programming with CodeWarrior. 

CodeWarrior Beginners

For a beginner’s tryst with CodeWarrior, see Core Tutorials. They 
cover the basics of using CodeWarrior. In addition, refer to the IDE 
User Guide for more in-depth information on creating, editing, 
compiling, and debugging your software projects.

For information on 
this target …

See this Web site

Linux http://www.linux.org

Mac OS http://devworld.apple.com

MIPS http://www.sgi.com/MIPS/

NEC http://www.nec.com/

Palm OS http://palmpilot.3com.com/5024.html

PowerPC Embedded http://www.mot.com/SPS/PowerPC/

Solaris http://docs.sun.com

Windows CE http://www.microsoft.com/msdn

Windows http://www.microsoft.com/msdn
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Language Beginners

For language basics, see the reference manuals for all supported 
languages (C, C++, and Java). Language manuals are located on 
your CodeWarrior CD at:

\\Documentation\CodeWarrior 

Also, refer to the various third party commercial books located at .

\\Documentation\Books 

Programming Beginners

For assistance in creating programs for a particular operating 
system, see the appropriate Targeting manual for the project. 
Targeting manuals provide all the information you need to 
successfully program a specific processor or operating system, 
including additional tutorials and examples.

Factory Updates
Metrowerks makes software updates available through its Web site 
to enhance features or correct bugs in an existing CodeWarrior 
product. You may download these updates and apply them to the 
CodeWarrior software installed on your computer.

For information on the latest patches to CodeWarrior software, see 
http://www.metrowerks.com .
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This chapter describes ways to contact Metrowerks with your 
questions on registration, site licensing, sales, and technical support. 

The sections in this chapter are:

• Contacting Metrowerks

• Registering a CodeWarrior Product

• Technical Support

• Sales, Renewals, and Site Licensing

• Worldwide Distributors

• CodeWarrior Factory Store

Contacting Metrowerks
Use the information below to contact Metrowerks:

Metrowerks Corporation
9801 Metric Blvd., Suite 100
Austin, TX-78758
U.S.A.

Or, contact Metrowerks by voice or fax  using these numbers:

tel: (800) 377-5416 (toll free in US only) or
 (512) 873-4700

fax: (512) 873-4900 
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Registering a CodeWarrior Product
To register your Metrowerks product and qualify for technical 
support and online factory updates, or, if you have questions on 
your registration, contact Metrowerks using the information below.

Questions on Registration

If you have any questions about registering a product with 
Metrowerks, send email to:

mailto:register@metrowerks.com

To Register Online

You can register your CodeWarrior product online by visiting:

http://www.metrowerks.com/register/

and filling in the handy form that appears there. 

To Register by Email

To register by email, fill in the Registration_Card form, copy it into an 
email message, then email it to:

mailto:register@metrowerks.com

To Register by Mail

To register by letter, fill in the Registration_Card form, print a copy 
and mail it to:

Metrowerks Corporation
ATTN: Dept 334
PO Box 9700
Austin, TX 78766-9700
U.S.A.

To Register by Fax

To register by fax, photocopy your registration card or fill out the 
Registration_Card form, then print a copy and fax it to:

fax: (512) 873-4901
ATTN: Dept 334
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Technical Support
Metrowerks offers a combination of free technical support as well as  
fee-based support for desktop development tools. For desktop 
development, there is a multi-tiered model that includes 30 days of 
free support from the date of the first incident. Other supported 
options include: pay-as-you-go, incident packages, and multi-user 
packages. For the latest information on technical support, visit: 

http://www.metrowerks.com/newsupport/

Submitting Technical Questions Online

You can submit a technical support question online at: 

http://www.metrowerks.com/contact/support/

Emailing Technical Questions

To submit a technical question via email, fill out the email_Tech-
_Question_Form form and email it to:

mailto:cw_support@metrowerks.com

Reporting Bugs

To report a bug, fill out the email_Bug_Report_Form form and email 
it to:

mailto:cw_bug@metrowerks.com 

Making Feature Requests

If you have a feature you would like to see implemented in a future 
release of a Metrowerks product, fill out the email_Suggestion_Form 
form and email it to:

mailto:cw_features@metrowerks.com 

NOTE All technical support forms are located at Release  Notes  > email  
Report  Forms  folder located on your CodeWarrior CD.
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Sales, Renewals, and Site Licensing
For information on a site license or buying a new Metrowerks’ 
product at a reduced price, for the U.S.A. and Canada,or for 
international sales, contact Metrowerks using the information 
shown below.

U.S. and Canada Distributors

For information on domestic sales, send email to:

mailto:sales@metrowerks.com

Or write:

Metrowerks Corporation 
ATTN: Sales
9801 Metric Blvd., Suite 100
Austin, TX 78758 
U.S.A.

Or fax:

fax: (512)873-4901

International sales, marketing, and licensing

For information on international sales, send email to:

mailto:intlsls@metrowerks.com

Or write:

Metrowerks Corporation 
ATTN: International Sales
9801 Metric Blvd., Suite 100
Austin, TX 78758 
U.S.A.

Or fax:

fax: (512)873-4901
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Worldwide Distributors
For information on contacting a distributor of Metrowerk’s 
products outside of the U.S.A. or Canada, visit our web site at:

http://www.metrowerks.com/buy/

Where you’ll find the latest list of Metrowerks’ distributors.

CodeWarrior Factory Store
The Factory Store is stocked with everything you need to become a 
complete CodeWarrior – manuals to bring you up to speed like the 
IDE User Guide, C/C++ Tools, as well as many others, and 
fashionable Geekware accoutrements like polo shirts, t-shirts, caps, 
and other accessories to keep you there in style.

To Order Geekware Online

To purchase Geekware online, visit:

http://www.metrowerks.com/geekware/

To Order Geekware by Phone

To purchase Geekware products in the U.S., use:

tel: (800) 377-5416
fax: (512) 873-4901

To purchase Geekware products internationally, use:

tel: +1 512 873 4700
Fax: +1 512 873 4901
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Metrowerks Software 
License Agreement

THIS METROWERKS SOFTWARE LICENSE AGREEMENT (“LICENSE”) IS AN 
AGREEMENT BETWEEN YOU AND METROWERKS CORPORATION 
(“METROWERKS”).  METROWERKS IS WILLING TO LICENSE THE 
ENCLOSED SOFTWARE TO YOU ONLY UPON THE CONDITION THAT YOU 
ACCEPT ALL OF THE TERMS CONTAINED IN THIS LICENSE.  PLEASE 
READ THIS LICENSE CAREFULLY BEFORE USING THE SOFTWARE, AS BY 
USING THE SOFTWARE INDICATES THAT YOU AGREE TO BE BOUND BY 
THE TERMS OF THIS LICENSE. IF YOU DO NOT AGREE TO THE TERMS OF 
THIS LICENSE, METROWERKS IS UNWILLING TO LICENSE THE SOFTWARE 
TO YOU, AND YOU SHOULD PROMPTLY RETURN THE UNUSED 
SOFTWARE TO THE PLACE WHERE YOU OBTAINED IT AND YOUR MONEY 
WILL BE REFUNDED. 

1. Grant of License. The application, demonstration, system and all other 
software accompanying this License, whether on CD-ROM or any other media 
(the “Software”) and the related documentation are licensed to you by 
Metrowerks according to the terms of this License.  This License allows you to use 
the Software on a single computer. You may also use a copy of the Software on a 
home or portable computer, as long as that extra copy is never running at the 
same time the Software is running on the primary computer on which you use the 
Software. You may make one additional copy of the Software in the form in 
which it is provided to you, only for backup purposes. You must reproduce on all 
copies you make of the Software the Metrowerks copyright notice and any other 
proprietary legends that are on the original copy of the Software. You may also 
transfer to another party all your license rights in the Software and related 
documentation by transferring to that party both the original media on which the 
Software and related documentation were provided and a copy of this License, 
provided that the other party reads and agrees to accept the terms and conditions 
of this License.  Immediately upon transfer, you have no further rights to use or 
own copies of the Software or related documentation and must destroy all copies 
in your possession or control.

2. Restrictions. The Software contains copyrighted material, trade secrets, and 
other proprietary material of Metrowerks and its licensors. You agree that in 
order to protect those proprietary materials, except as expressly permitted by 
applicable legislation, you will not decompile, reverse engineer, disassemble or 
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otherwise reduce all or any part of the Software to human-readable form unless 
Metrowerks provided it to you in human-readable form.  You may not modify, 
rent, lease, loan, distribute or create derivative works based upon the Software in 
whole or in part, except as expressly permitted in Section 3.  If the Software is 
labeled as an academic version or is otherwise licensed to you for academic use, 
you may not use the Software for commercial product development, but you may 
use the Software to develop freeware or shareware. If the Software licensed to 
you is part of the Discover Programming series, you may not use the Software to 
develop any product for distribution, whether commercial, freeware, or 
shareware.  

3. Software Modification and Redistribution. Appendix A to this License lists 
the specific portions of the Software which you may distribute according to the 
terms of this License ("Distributable Code").  If Metrowerks has provided 
Distributable Code to you in human-readable form, you may modify the 
Distributable Code and the resulting modifications will also be considered 
Distributable Code.  In order to protect Metrowerks' and Metrowerks' licensors' 
intellectual property rights in the Software, you may modify and distribute 
Distributable Code only according to the following terms: You may distribute 
Distributable Code only in executable object code form and only as incorporated 
into application programs you create using the Software and which have 
substantial value in addition to the Distributable Code.  You may distribute 
Distributable Code incorporated in such applications to end users directly or 
indirectly through dealers, distributors, VARs, OEMs and other relicensors, but 
all distribution, whether to end users or relicensors, must be made pursuant to a 
valid written agreement that is at least as protective of Metrowerks' and 
Metrowerks' licensors' rights as this License. In no event shall you expand or 
attempt to expand Metrowerks' warranty or other obligations for any portion of 
the Software beyond those obligations set forth in this License nor extend those 
obligations to end users or relicensors of your applications.  Last, you must 
reproduce on each copy of such applications a copyright notice that clearly states: 
"Copyright (c) by [Licensee Name] and its Licensors."  Under no circumstances 
are you permitted to distribute any portions of the Software not listed on 
Appendix A, nor to distribute any portions of the Software (including those listed 
on Appendix A) in human-readable form, unless (i) specific license terms that 
may accompany such portions of the Software on the media containing the 
Software expressly authorize you to distribute such portions of the Software, in 
object code or human-readable form as the case may be, or (ii) you have express 
written authorization from an authorized officer of the company which owns that 
portion of the Software. In the event you distribute such portions of the Software 
based upon express authorization by one of the two means stated, you must 
adhere strictly to the specific terms of such authorization in addition to the terms 
of this license. You agree to indemnify and hold Metrowerks harmless from any 
damages, costs, or expenses Metrowerks may suffer as a result of your 
distribution, under either of the forms of permission described in the previous 
sentence, of any portion of the Software owned by a third party.

4. Ownership. The Software and documentation are licensed, not sold, to you for 
use only under the terms of this License, and Metrowerks reserves all rights not 
expressly granted to you in this License. You own the media on which the 
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Software and documentation are recorded but Metrowerks and/or Metrowerks' 
licensors retain title to the Software and related documentation, and all 
intellectual property rights therein.

5. Termination. This License is effective until terminated. You may terminate this 
License at any time by destroying all copies of the Software and related 
documentation in your possession or control. This License will terminate 
immediately without notice from Metrowerks if you fail to comply with any 
provision of this License. Upon termination you must destroy all copies of the 
Software and related documentation in your possession or control. 

6. Export Law Assurances. You agree and certify that neither the Software nor 
any other technical data received from Metrowerks, nor the direct product 
thereof, will be exported outside the United States except as authorized and as 
permitted by the laws and regulations of the United States. If the Software has 
been rightfully obtained by you outside of the United States, you agree that you 
will not re-export the Software nor any other technical data received from 
Metrowerks, nor the direct product thereof, except as permitted by the laws and 
regulations of the United States and the laws and regulations of the jurisdiction in 
which you obtained the Software. 

7. Government End Users.  If you are acquiring the Software on behalf of any 
unit or agency of the United States Government, the following provisions apply.  
The Software constitutes a "commercial item", as that term is defined at Federal 
Acquisition Regulation (FAR) 2.101 (Oct. 1995), consisting of "commercial 
computer software" and "commercial computer software documentation", as such 
terms are used in FAR 12.212 (Sept. 1995), and is provided to the U.S. 
Government only as commercial software (with "Restricted Rights", if applicable).  
Use, duplication, or disclosure by the U.S. Government is subject to restrictions 
set forth in this license agreement and as provided in DFARS 227.7202-1(a) and 
227.7202-3(a) (1995), DFARS 252.227-7013(c)(1)(ii) (OCT 1988), FAR 12.212(a) 
(1995), FAR 52.227-19, or FAR 52.227-14 (ALT III), as applicable.

8. Limited Warranty on Media. Metrowerks warrants the media on which the 
Software is recorded to be free from defects in materials and workmanship under 
normal use for a period of ninety (90) days from the date of purchase as 
evidenced by a copy of the receipt. Metrowerks' entire liability and your exclusive 
remedy will be replacement of the media not meeting Metrowerks limited 
warranty returned to Metrowerks with a copy of the receipt. Metrowerks will 
have no responsibility to replace any media damaged by accident, abuse or 
misapplication. ANY IMPLIED WARRANTIES ON THE MEDIA, INCLUDING 
THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A 
PARTICULAR PURPOSE, ARE LIMITED IN DURATION TO NINETY (90) 
DAYS FROM THE DATE OF DELIVERY. THIS WARRANTY GIVES YOU 
SPECIFIC LEGAL RIGHTS, AND YOU MAY ALSO HAVE OTHER RIGHTS 
WHICH VARY BY JURISDICTION. 

9. Disclaimer of Warranty.  THE SOFTWARE, RELATED DOCUMENTATION, 
ANY APPLICATIONS CREATED WITH THE SOFTWARE ARE PROVIDED "AS 
IS" AND WITHOUT WARRANTY OF ANY KIND.  YOU EXPRESSLY 
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ACKNOWLEDGE AND AGREE THAT USE OF THE SOFTWARE AND 
RELATED DOCUMENTATION IS AT YOUR SOLE RISK.  SHOULD THE 
SOFTWARE OR RELATED DOCUMENTATION PROVE DEFECTIVE, YOU 
(AND NOT METROWERKS OR ANY METROWERKS REPRESENTATIVE) 
ASSUME THE ENTIRE COST OF ALL NECESSARY SERVICING, REPAIR OR 
CORRECTION. METROWERKS AND METROWERKS ' LICENSORS (FOR THE 
PURPOSES OF THIS SECTION 9, METROWERKS AND METROWERKS' 
LICENSORS SHALL BE COLLECTIVELY REFERRED TO AS "METROWERKS") 
EXPRESSLY DISCLAIM ALL OTHER WARRANTIES WITH RESPECT TO THE 
SOFTWARE AND RELATED DOCUMENTATION, WHETHER SUCH 
WARRANTIES ARE EXPRESS OR IMPLIED, INCLUDING, BUT NOT LIMITED 
TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A 
PARTICULAR PURPOSE AND NONINFRINGEMENT.  WITHOUT LIMITING 
THE GENERALITY OF THE FOREGOING, METROWERKS MAKES NO 
WARRANTY OR REPRESENTATION THAT THE FUNCTIONS CONTAINED 
IN THE SOFTWARE WILL MEET YOUR REQUIREMENTS, THAT THE 
OPERATION OF THE SOFTWARE WILL BE UNINTERRUPTED OR ERROR-
FREE, THAT DEFECTS IN THE SOFTWARE WILL BE CORRECTED, NOR 
WITH RESPECT TO THE CORRECTNESS, ACCURACY, OR RELIABILITY OF 
THE SOFTWARE AND RELATED DOCUMENTATION. METROWERKS 
DISCLAIMS ANY AND ALL EXPRESS OR IMPLIED WARRANTIES OF ANY 
KIND, AND YOU EXPRESSLY ASSUME ALL LIABILITIES AND RISKS, FOR 
ANYONE' S USE OR OPERATION OF ANY APPLICATION PROGRAMS YOU 
MAY CREATE WITH THE SOFTWARE.  YOU ACKNOWLEDGE AND AGREE 
THAT THE SOFTWARE HAS NOT BEEN DESIGNED, TESTED, OR 
MANUFACTURED FOR USE IN DEVELOPING APPLICATIONS WHERE THE 
FAILURE, MALFUNCTION, OR ANY INACCURACY OF THE APPLICATION 
CARRIES A RISK OF DEATH, SERIOUS BODILY INJURY, OR DAMAGE TO 
TANGIBLE PROPERTY, INCLUDING, BUT NOT LIMITED TO, USE IN 
FACTORY CONTROL SYSTEMS, MEDICAL DEVICES OR FACILITIES, 
NUCLEAR FACILITIES, AIRCRAFT OR AUTOMOBILE NAVIGATION OR 
COMMUNICATION, EMERGENCY SYSTEMS, OR OTHER APPLICATIONS 
WITH A SIMILAR DEGREE OF POTENTIAL HAZARD.  NO ORAL OR 
WRITTEN INFORMATION OR ADVICE GIVEN BY METROWERKS OR ANY 
OF ITS EMPLOYEES, REPRESENTATIVES, OR RESELLERS SHALL CREATE 
ANY WARRANTY IN ADDITION TO THOSE GIVEN HEREIN. SOME 
JURISDICTIONS DO NOT ALLOW THE EXCLUSION OF IMPLIED 
WARRANTIES, SO THE ABOVE EXCLUSION MAY NOT APPLY TO YOU. 

10. Limitation of Liability. UNDER NO CIRCUMSTANCES SHALL 
METROWERKS BE LIABLE FOR ANY INCIDENTAL, SPECIAL OR 
CONSEQUENTIAL DAMAGES THAT RESULT FROM THE USE OR INABILITY 
TO USE THE SOFTWARE OR RELATED DOCUMENTATION UNDER ANY 
THEORY, INCLUDING CONTRACT, TORT, OR NEGLIGENCE, EVEN IF 
METROWERKS HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH 
DAMAGES. SOME JURISDICTIONS DO NOT ALLOW THE LIMITATION OR 
EXCLUSION OF LIABILITY FOR INCIDENTAL OR CONSEQUENTIAL 
DAMAGES SO THE ABOVE LIMITATION OR EXCLUSION MAY NOT APPLY 
TO YOU. 
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IN NO EVENT SHALL METROWERKS' TOTAL LIABILITY TO YOU FOR ALL 
DAMAGES, LOSSES, AND CAUSES OF ACTION (WHETHER IN CONTRACT, 
TORT (INCLUDING NEGLIGENCE) OR OTHERWISE) EXCEED THE 
AMOUNT PAID BY YOU FOR THE SPECIFIC LICENSE OF THE SOFTWARE 
AND RELATED DOCUMENTATION TO WHICH THE LIABILITY IS 
RELATED. 

11. Controlling Law and Severability. THIS LICENSE SHALL BE GOVERNED 
BY AND CONSTRUED IN ACCORDANCE WITH THE LAWS OF THE UNITED 
STATES AND THE STATE OF CALIFORNIA, EXCEPT FOR ITS CONFLICT OF 
LAWS PRINCIPLES. If for any reason a court of competent jurisdiction finds any 
provision of this License, or portion thereof, to be unenforceable, that provision of 
the License shall be enforced to the maximum extent permissible so as to effect 
the intent of the parties, and the remainder of this License shall continue in full 
force and effect. 

12. Complete Agreement. This License constitutes the entire agreement between 
the parties with respect to the use of the Software and related documentation and 
supersedes all prior or contemporaneous understandings or agreements, written 
or oral, regarding such subject matter. No amendment to or modification of this 
License will be binding unless in writing and signed by an authorized officer of 
Metrowerks. 

Should you have any questions or comments concerning this License, please do 
not hesitate to contact Metrowerks Corporation at 9801 Metric Boulevard, Suite 
#100, Austin, TX, 78758, USA. ATTN: Warranty Information or by email: 
mailto:info@metrowerks.com

Appendix A - Redistribution Information for Metrowerks Software:  
Distributable Code

The CodeWarrior Installer contains a list that describes the portions of the 
Software that you may incorporate into your own programs and distribute 
according to the terms of Section 3 of the License. You may not incorporate into 
your programs nor distribute any portion of the Software that is not listed here 
nor distribute any portion of the Software in human-readable form unless you 
obtain express permission to do so, as set forth in Section 3.
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